Forum Jump :

Author Message


Posts: 41
Rank:


Level: Member

Country: nl
Location: Amsterdam
Occupation: PHP Developer
Age: 31
In-game name: [DD]Grezvany13

 
#16 Posted at 2013-03-26 10:06        
     
# coolshooter : Ok and how can you place the transparent logo into the game, does it support png? Also, i heard that the game might support something like turning green into transparent like with the counter strike logo
It's simple ;)

- Place the .paa file (eg. mylogo.paa) at the same location as your squad.xml file
- At the squad.xml file, make sure you have the following:
<squad nick="AC">
   <title>AC</title>
   <name>A Clan</name>
   <email>N/A</email>
   <web>N/A</web>
   <picture>mylogo.paa</picture>
   <member>
   // member stuff
   </member>
</squad>

As for .png images; yes they do work but without transparency (just like .jpg images).

Proud member of Double Dutch Clan - Dutch Multigaming Clan since 2007
Member of Tangodown - Tactical Gaming Community

Author Message


Posts: 2
Rank:


Level: Member

Country: ca
Location:
Occupation:
Age:
In-game name: Captain Mullraugh [Foxtrot]

 
#17 Posted at 2013-04-11 04:54        
     
Hi, I've had a squad.xml for quite some time now, but I can't seem to figure out how to add my friends to it. I've added their names, player ID's, etc to the xml and everything works except the Squad Logo and the Tag that appears in square brackets after their name -even though it works fine for me. I have no idea what I did wrong, and every attempt to find out just leads me to this, or another thread dealing with "how to make a squad xml" instead of "how to add people to a squad xml".

So. Here's my exact xml file, with the Player ID's not included for security reasons. If you can Identify what's wrong and how to fix it, that'd be greatly appreciated!

<?xml version="1.0"?>
<!DOCTYPE squad SYSTEM "squad.dtd">
<?xml-stylesheet href="squad.xsl?" type="text/xsl"?>
<squad nick="Able Company">
<name>Able Company, 2nd Battalion, 506th Parachute Infantry Regiment, 101st Airborne</name>
<email>N/A</email>
<web>Invasion 1944</web>
<picture>Able Logo.paa</picture>
<title>Able Company, 101st Airborne</title>
<member id="********" nick="Captain Mullraugh">
<name>Mullraugh</name>
<email>N/A</email>
<icq>N/A</icq>
<remark>Captain Mullraugh of Able Company, 2nd Battalion, 506th Parachute Regiment, 101st Airborne</remark>
</member>
<member id="*********" nick="Corporal Ty">
<name>Ty</name>
<email>N/A</email>
<icq>N/A</icq>
<remark>Corporal Ty of Able Company, 2nd Battalion, 506th Parachute Regiment, 101st Airborne</remark>
</member>
<member id="*********" nick="Private Ryan">
<name>Ryan</name>
<email>N/A</email>
<icq>N/A</icq>
<remark>Private Ryan of Able Company, 2nd Battalion, 506th Parachute Regiment, 101st Airborne</remark>
</member>
<member id="*********" nick="Sergeant Aj">
<name>Aj</name>
<email>Thegreataj@live.com</email>
<icq>N/A</icq>
<remark>Sergeant Aj of Able Company, 2nd Battalion, 506th Parachute Regiment, 101st Airborne</remark>
</member>
<member id="*********" nick="Sergeant Oryon">
<name>Oryon</name>
<email>N/A</email>
<icq>N/A</icq>
<remark>|Sergeant Oryon of Able Company, 2nd Battalion, 506th Parachute Regiment, 101st Airborne</remark>
</member>
<member id="*********" nick="Corporal Ukie">
<name>Ukie</name>
<email>N/A</email>
<icq>N/A</icq>
<remark>Corporal Ukie of Able Company, 2nd Battalion, 506th Parachute Regiment, 101st Airborne</remark>
</member>
<member id="*********" nick="Private PolarisC8">
<name>Polaris</name>
<email>N/A</email>
<icq>N/A</icq>
<remark>Private Polaris of Able Company, 2nd Battalion, 506th Parachute Regiment, 101st Airborne</remark>

</squad>



---
Sorry for inability to see an answer to this problem that could possibly be in this thread. But I can't find any help anywhere.


Advertisement


Author Message


Posts: 3
Rank:


Level: Member

Country: uk
Location:
Occupation:
Age:
In-game name:

 
#18 Posted at 2013-10-14 13:53        
     
# Rubber : Hi guys.

just check inside your profile file, cause the URL is converted uppercase if u do any mod in the profile inisde arma, so check in your document ArmA3Alpha nick.profile and write it lower case it should work without any modify

;)

Cheers

Could you explain how to do this exactly please?
I believe i have set the .xml/.paa & sqd_logo.png files up correctly but am unable to view my arm/Vehicle badge whilst playing online.
I can view my squad logo as transparent here http://www.ifix-yourpc.com/roc/nem/squad.xml

<?xml version="1.0"?>
<!DOCTYPE squad SYSTEM "squad.dtd">
<?xml-stylesheet href="squad.xsl?" type="text/xsl"?>
<squad nick="{RoC}">
<name>Rifle Only Clan</name>
<email>N/A</email>
<web>http://www.rifleonlyclan.com</web>
<picture>logo.paa</picture>
<title>PA</title>
<member id="11111111111111111" nick="{RoC}THE-Nemesis">
<name>Nem</name>
<email>N/A</email>
<icq>N/A</icq>
<remark>Don't panic, Nem is here</remark>
</member>
</squad>

Just cant understand why it isn't working..

Added 5 hours 51 minutes later:

In my Arma3 Player profile where squad URL is, should i have the link with squad.xml at the end?
ie www.blablabla.com/nem/squad.xml ?
or just www.blablabla.com/nem/ ?

Thanks,, pulling my hair out now.

This post was edited by THE-Nemesis (2013-10-14 20:09, ago)


Author Message


Posts: 20251
Rank:


Level: Super Admin

Country: nl
Location: The Netherlands
Occupation:
Age: 41
In-game name: Foxhound

 
#19 Posted at 2013-10-14 21:20        
     
You need to full url, including "squad.xml".
Is that pic just not to big to be used online? Both in size and file size. I have no idea wether there is a limit, so you could try with a really small image.

Visit my family webshop desteigerhoutshop.nl.

Author Message


Posts: 3
Rank:


Level: Member

Country: uk
Location:
Occupation:
Age:
In-game name:

 
#20 Posted at 2013-10-14 21:30        
     
# Foxhound : You need to full url, including "squad.xml".
Is that pic just not to big to be used online? Both in size and file size. I have no idea wether there is a limit, so you could try with a really small image.
I remembered i used 512x512 and it worked fine on A2 for the whole clan.
I did try reducing this to 256x256 then convert to paa with texview2, still nothing.

Getting frustrated lol


Author Message


Posts: 20251
Rank:


Level: Super Admin

Country: nl
Location: The Netherlands
Occupation:
Age: 41
In-game name: Foxhound

 
#21 Posted at 2013-10-14 21:52        
     
Your logo is a png?

have you placed the logo in your folder called it logo.paa (convert with texview2), and also named it logo.paa in the squad.xml picture?


Some good info here: http://forums.bistudio.com/showthread.php?149304-Template-ArmA-3-for-file-quot-squad-xml-quot

Visit my family webshop desteigerhoutshop.nl.

Author Message


Posts: 3
Rank:


Level: Member

Country: uk
Location:
Occupation:
Age:
In-game name:

 
#22 Posted at 2013-10-15 00:26        
     
Followed that,,, still stuck.
Hoping it isn't something really simple my end.


Author Message


Posts: 1
Rank:


Level: Member

Country: us
Location:
Occupation:
Age:
In-game name:

 
#23 Posted at 2013-11-16 01:25        
     
Alright so I've made this Squad xml for my milsim unit and I've gotten extremely good at it, I have no problems getting people on the xml and it working in game except for one person... Out of the 25+ people I have on the xml his is the only one that will not work. Now I'm sure that the Name is correct in game and on my xml. The Squad URL is in his Arma 2 player profile correctly with no extra accidental space, and his Player ID is correct. BUT... Here's where I think the problem is but im not sure. His player ID is 325673AX. This is the first ID I've seen that has letters in it and I can't find a solution anywhere on the internet. So I'm not sure if that is exactly the problem or what but any help would be greatly appreciated.


Author Message


Posts: 25
Rank:


Level: Member

Country: us
Location: Hawaii
Occupation: Ex-Military
Age: 25
In-game name: THEHELPMAN

 
#24 Posted at 2015-01-02 02:40        
     
Does it still work? Last time i tried it, it didn't work.


Author Message

Rick  

One of Armaholic's finest ..... by presence....


Posts: 256
Rank:


Country: ca
Location: Alberta
Occupation: Sodbuster
Age: 26
In-game name: Rick

 
#25 Posted at 2015-01-10 05:51        
     
It works in A3 for sure.

I haven't played A2 in a long time but the last time I did it was still working there too. I doubt that's changed.

I am very macho.





Tags: Guide, Squad, Team, Xml