Forum Jump :

Author Message


Posts: 56
Rank:


Level: Member

Country: au
Location: Mid North Coast
Occupation: Personal Care Assistant
Age: 42
In-game name:

 
#1 Posted at 2013-04-03 07:09        
     
Hi guys hope someone can help a script noob.
So i have a script to spawn in an exfill chopper and want it to travel to several wp. At the first i want it to land and pick up 4 guys and wait untill they are all aboard (also check if they are dead).Now the thing does spawn but its at the default lower left corner of the map but atleast it spawns. What is realy stuffing up is that at the first WP the chopper does not land and continues straight on to the next WP.
This is waht i have

any help apreciated :)

This post was edited by Bejmo75 (2013-04-04 15:09, ago)


Author Message


Posts: 56
Rank:


Level: Member

Country: au
Location: Mid North Coast
Occupation: Personal Care Assistant
Age: 42
In-game name:

 
#2 Posted at 2013-04-08 12:15        
     
Ok so can someone at least tell me how to call Zorilias garrison script from setwaypointstatemants. I have this so far

_point1 = getmarkerPos "WPOFQRF1_1";
_wp0 = OFQRF1 addWaypoint [ _point1, 10];
_wp0 setWaypointType "MOVE";
_wp0 setWaypointStatements ["true", "Null = [OFQRF1,100,TRUE] execVM "Garrison_script.sqf";"];
_wp0 setWaypointSpeed "FULL";


and it keeps giving me a Missing ]. I have searched the forums and tried a ton of variations with no joy PLEASE can someone put me out of my missery. :(

Added 18 hours 14 minutes later:

Got it to work like this.

Boss1 = OFQRF1 createUnit ["TK_INS_Soldier_TL_EP1", getMarkerPos "OFQRF1", ["OFQRF1"], 1, "FORM"];
OFQRF1 createUnit ["TK_INS_Soldier_AR_EP1", getMarkerPos "OFQRF1", ["OFQRF1"], 1, "FORM"];
OFQRF1 createUnit ["TK_INS_Soldier_EP1", getMarkerPos "OFQRF1", ["OFQRF1"], 1, "FORM"];
OFQRF1 createUnit ["TK_INS_Soldier_EP1", getMarkerPos "OFQRF1", ["OFQRF1"], 1, "FORM"];
OFQRF1 createUnit ["TK_INS_Soldier_Sniper_EP1", getMarkerPos "OFQRF1", ["OFQRF1"], 1, "FORM"];
OFQRF1 createUnit ["TK_INS_Bonesetter_EP1", getMarkerPos "OFQRF1", ["OFQRF1"], 1, "FORM"];

_point1 = getmarkerPos "WPOFQRF1_1";
_wp0 = OFQRF1 addWaypoint [ _point1, 10];
_wp0 setWaypointType "MOVE";
_wp0 setWaypointStatements ["true", ""];
_wp0 setWaypointSpeed "FULL";


OFQRF1 allowfleeing .6;

Sleep 1;

nul = [Boss1,60,TRUE] execVM "Garrison_script.sqf";

Still no freakin idea how the hell SetWaypointStatemants works tho :(

This post was edited by Bejmo75 (2013-04-09 06:30, ago)


Advertisement


Author Message


Posts: 48
Rank:


Level: Member

Country: au
Location:
Occupation:
Age:
In-game name:

 
#3 Posted at 2013-04-09 08:33        
     
I know you fixed it with a work around but I think

_wp0 setWaypointStatements ["true", "Null = [OFQRF1,100,TRUE] execVM "Garrison_script.sqf";"];

needs to be..

_wp0 setWaypointStatements ["true", "Null = [OFQRF1,100,TRUE] execVM ""Garrison_script.sqf"""];