Forum Jump :

Author Message


Posts: 1
Rank:


Level: Member

Country: se
Location:
Occupation:
Age:
In-game name:

 
#1 Posted at 2014-12-26 17:43        
     
Hello!
I'm trying to learn how to make an object mod, so just to get to grips with how things works i have made a simple cube, of asphalt. I've come so far that the cube will show up in game but only if I don't add any texture to it. With textures the pbo-making will fail. I'm using pboProject and I get an error message that the texture file is missing. The file is there and I can see the texture in Object Builder though, with Direct3D enabled.

The Noisy output from from pboProject says:

//forcing arma raP
class CfgPatches
{
class block_tut_01
{
units[] = {""};
weapons[] = {};
requiredVersion = 0.1;
requiredAddons[] = {"A3_Structures_F_Civ_InfoBoards"};
};
};
class CfgAddons
{
class block_tut_01
{
list[]={"Block_Tut"};
};
};
class CfgVehiclesClasses
{
class block_tut_01
{
displayName="Block Tut 01";
};
};
class cfgvehicles
{
class Thing;
class block_tut: Thing
{
scope = 2;
model = "p:\grejer\kub\kubb.p3d";
displayName="Block_Test";
VehiclesClass = "block_tut_01";
destrType = "DestructNo";
};
};
scanning cfgPatches...ok (altered)
rapify x32UnicodeVersion 1.75, Dll 4.87 "config.cpp"
No Error(s)
Output is to config.bin

grejer\kub\texHeaders.bin
1 File(s) copied
grejer\kub\texture01_co.paa
1 File(s) copied
1 file(s) copied.
1 file(s) copied.
1 file(s) copied.
1 file(s) copied.
1 file(s) copied.
1 file(s) copied.
1 file(s) copied.
1 file(s) copied.
1 file(s) copied.
1 file(s) copied.
Building entries:...
config.bin
texture01_co.paa
kubb.p3d scanning...
p3d: P:\temp\grejer\kub\kubb.p3d
missing \p:\grejer\kub\texture01_co.paa



and binlog:

Copy of file p:\grejer\kub\texture01_co.paa -> P:\temp\p:\grejer\kub\texture01_co.paa fail with: Felaktig syntax för filnamn, katalognamn eller volymetikett.

!copy returned error 2: No such file or directory
Convert model grejer\kub\kubb.p3d -> P:\temp\grejer\kub\kubb.p3d
<model = "grejer\kub\kubb.p3d">
</model>
Creating process: "D:\Spelgrejer\Steam\steamapps\common\Arma 3 Tools\BinMake\binMake.exe" -C P:\ "p:\grejer\kub\texture01_co.paa" "P:\temp\p:\grejer\kub\texture01_co.paa"


I can see the path looks wierd but I don´t know how to fix that. Anyone have a suggestion?

Added 18 hours 55 minutes later:

Got it working! Was probably just a file path thing. In Object builder -> face properties I had to remove the p:\ from the file path.

This post was edited by UffeGK (2014-12-27 12:39, 1085 days ago)


Author Message


Posts: 325
Rank:


Level: Member

Country: br
Location:
Occupation: deanosbeano
Age:
In-game name: deanosbeano

 
#2 Posted at 2014-12-27 12:57        
     
The problem may not be obvious because Bis a low local reading of p drive by the game but thats a major flaw
Esentially your config shoul not have not have a path of P: \.... so pboproject correct to recognise a mistake but Bis tools are poor made so will allow as long as path is true no matter later conesquene

In oxygen options there is path to texture option putthere p:\ when thats done you will see when a texture is applied it will now omit p:\ and have for example greger\kub\texure.paa

In config cpp your model path take away the p:\ and make model = \grejer\kub\kubb.p3d";

Some times there is a different requirement as to whether a path will start with \ or without a rule I long forgot but if you struggle test methodically and its soon correct

http://forums.bistudio.com/showthread.php?40226-ECL's-record-breaking-attempt-players-on-one-serve&p=619994&viewfull=1#post619994