Forum Jump :

Author Message


Posts: 4
Rank:


Level: Member

Country: uk
Location:
Occupation:
Age:
In-game name: morrisons90

 
#1 Posted at 2015-05-10 00:09        
     
Im trying to use this function in the simplest format and just nothings happening. I have a trigger with BluFor present as condition and
groupName = [getMarkerPos "spawnPoint1", EAST, 10] call BIS_fnc_spawnGroup;
as the on act. I have the marker called spawnpoint1 and even have a east side unit off in a corner in the map.
When my blufor unit walks into it Nothing the trigger works as hints I put in work.

Don't know if the function module is necessary as I read it is not but the init of it creates a script error if I put in.

I know Im missing something very simple somewhere can someone see what it is?

Thanks Morrisons.


Author Message


Posts: 1589
Rank:


Level: Member

Country: pf
Location: Tahiti
Occupation: too many Arma
Age: 59
In-game name: Kobayashi Maru

 
#2 Posted at 2015-05-10 04:27        
     
I'm afraid it's a bug: http://feedback.arma3.com/view.php?id=10532

PLEASE CONTACT ME ON BI FORUMS FOR ANY SCRIPT / MOD QUESTION. TKS

Advertisement


Author Message


Posts: 51
Rank:


Level: Member

Country: ca
Location: Victoria, British Columbia
Occupation: Canadian Forces Weapon Technician
Age:
In-game name: PiZZADOX

 
#3 Posted at 2015-11-06 01:06        
     
Use corepatch (beta version of both arma 2 and operation arrowhead in steam) To fix the error spam via the functions module.
The bug is with the randomization of unit count, it is easy to work around this. Simply do a random check so it "rolls a dice" and chooses from a random array of unit types (Squad, Fireteam, etc) and execute the spawngroup with the local variable defined by the random choice of array.