Forum Jump :

Author Message


Posts: 5
Rank:


Level: Member

Country: uk
Location:
Occupation: Programmer
Age:
In-game name:

 
#1 Posted at 2015-09-29 23:15        
     
hello all

I'm new to making/hosting arma2 OA server.

i've managed to work out alot, unfortunatly I have encountered a odd error.

so i start the server with the server file chosen. but the console keeps doing this

22:58:20 Mission Takistan Life: Revolution read from bank.
22:58:28 Mission Takistan Life: Revolution read from bank.
22:58:31 Mission Takistan Life: Revolution read from bank.
22:58:46 Mission Takistan Life: Revolution read from bank.

i've waited like 10minutes, and tried logging in to the server, but it just says "waiting on host"

i've tried other maps and they work, the file is from the steam what comes with the Installer, am I missing something?





--here is my server.cfg file
maxPlayers = 40;
motd[]={"Welcome.. Server is undergoing BETA Testing."};
steamPort = 2303;
steamQueryPort = 2304;

//admin stuff
password = ""; // Password for joining, eg connecting to the server
passwordAdmin = ""; // Password to become server admin. When you're in Arma MP and connected to the server, type '#login '
serverCommandPassword = "";
logFile = "defaultserver\server_console.log";

//voting rules
//VoteThreshold=25.33;
//voteMisssionPlayers = 100;
checkfiles[]={};
reportingIp="arma2oapc.master.gamespy.com"
persistent = 1;
upnp=1;
verifySignatures = 2;
//vonCodecQuality = 10;

//ingame rules

doubleIdDetected = "command";
onUserConnected = "command";
onUserDisconnected = "command";

kickDuplicate = 1;
regularCheck = "command";
BattlEye = 1;
timeStampFormat = "short";
forceRotorLibSimulation = 0;


allowedFilePatching = 0;
allowedLoadFileExtensions[] = {"hpp","sqs","sqf","fsm","cpp","paa","txt","xml","inc","ext","sqm","ods","fxy","lip","csv","kb","bik","bikb","html","htm","biedi"};
allowedPreprocessFileExtensions[] = {"hpp","sqs","sqf","fsm","cpp","paa","txt","xml","inc","ext","sqm","ods","fxy","lip","csv","kb","bik","bikb","html","htm","biedi"};
allowedHTMLLoadExtensions[] = {"htm","html","xml","txt"};
allowedHTMLLoadURIs[] = {};
//equalModRequired = 1; // Outdated. If set to 1, player has to use exactly the same -mod= startup parameter as the server.


//signature ID
onUnsignedData = "Kick (_this select 0)";
OnHackedData = "Kick (_this select 0)";
onDifferentData = "Kick (_this select 0)";

class Missions
{
class takistan
{

template=anarchyinthetk.takistan;
difficulty="Regular";
};
};]


Author Message


Posts: 635
Rank:


Level: Member

Country: uk
Location: N.W.
Occupation:
Age: 29
In-game name: big_wilk

 
#2 Posted at 2015-09-30 11:48        
     
I've only ever got that error for not loading all the mods required in the senario are you sure you have all the mods / data files needed for your default mission? (might be wrong but rtp on the server probably will show if this is the case).

Also I'm not sure about:

reportingIp="arma2oapc.master.gamespy.com"

Haven't set up a server for a2 in a while so not sure if that is valid any more think it should a staem address.

There could be another reason I've missed but try and look at those things.


Advertisement


Author Message


Posts: 5
Rank:


Level: Member

Country: uk
Location:
Occupation: Programmer
Age:
In-game name:

 
#3 Posted at 2015-10-02 19:29        
     
Hey there,

i do not believe there are any requirements,

as the file is what I got when I downloaded the game from Steam,
but I think you game me the solution, when you said that I might be missing something,

I went in the game, and tried to host it, from my game and not the server and it came up with missing files, so I made a quick search on bing, and the answer was in the first link, that I need arma 2 & arma 2 OA, both ran once,
as some 1 had the same error message as I got, and he fixed it by installing arma 2 and running the client for arma 2, once.






Tags: Takistan