Forum Jump :

Author Message


Posts: 1
Rank:


Level: Member

Country: us
Location:
Occupation:
Age: 32
In-game name:

 
#1 Posted at 2017-01-26 07:30        
     
Hi Everyone, I'm having a lot of trouble and I'm hoping someone can help me. I have read many threads (including this one) and watched a lot of tutorials online and no one seems to be having the problem that I'm having. My problem is when I paste a camera location into the intro.sqs file, or multiple camera spots and then preview them, it only stays on the first camera position and never changes to the next. I tried doing the exact same thing the tutorials did and it's not working for me. To go into detail, I placed the unit and typed this exec "camera.sqs" in the unit's init box. Then I went into notepad and created a file name intro.sqs and saved it all files. then I placed this in the beginning of file:

titlecut [" ","BLACK IN",1]
_camera = "camera" camcreate [0,0,0]
_camera cameraeffect ["internal", "back"]

I then went back into game and placed the other units, then got the camera angle and left clicked. I alt+tab out and pasted it in the intro.sqs file. It pasted like this:

;comment "1:56:16";
_camera camPrepareTarget [-95470.67,2273.74,-14078.25];
_camera camPreparePos [3515.88,3621.10,2.00];
_camera camPrepareFOV 0.700;
_camera camCommitPrepared 0

Now every tutorial and picture has shown that top line as ;=== 1:56:16 instead of what my game pasted. I tried changing it but I get the same problem. I also noticed that at the end every position in every tutorial and picture is @camCommitted_camera. Now, none of the tutorials or threads or guides have mentioned if that line is suppose to get pasted in or if that must be added manually. If it needs to be pasted in, why is my game not doing that. If not, I have tried to add it manually and still no change it still never changes to the next camera spot. I tried changing the camCommitPrepared 0 or a number which is suppose to make the camera pan to the next spot...... but that didn't work. I tried adding the ~and a number which from what I read is suppose to make the camera wait, then move to the next spot or wait then start panning, however my intro seems to be stuck on the wait forever part. My only conclusions are A) I'm missing something even though I have copied my file as I have seen from everything I read and/or watched or B) I have the one copy of Arma 2 that is designed to not do anything that it's suppose to lol. I'm also having trouble with briefings but i'm not going into that lol. If anyone can help it will be grealy appreciated. thank you

- Chris

This post was edited by Foxhound (2017-01-26 08:09, 265 days ago)