Forum Jump :

Author Message


Posts: 10
Rank:


Level: Member

Country: us
Location: Washington coast
Occupation: jack of all trades, master of none
Age: 54
In-game name: [CoFR]October

 
#1 Posted at 2010-07-06 05:50        
     
Hi,

I run a desktop that besides gaming is designed for music production. I won't go into all the fluff here except to say that my sound card is an M-Audio Delta 44. When I started either ArmA2 or OA (Steam versions) I noticed that the game sound quality was poor. Alt-Tab'ing out to the desktop shows that my sound card has reverted to an 11025 Hz sample rate, not much better than AM radio.

This (these) are the only game(s) I have that do this. Everything else, music, games, both in Steam and out, are at a nice 44100 Hz (4x as high quality!), the consumer level standard. The only other application I have that even remotely comes close to this sort of behavior is RisingAV Free which has a stupid little lion animation that kicks it down to 22050 Hz when it "roars". I go in and manually put it back at 44100 Hz and everything is fine again.

I suspect that the game is reverting to some legacy setting for sound chips that aren't recognized but why it doesn't just hand it off to the Microsoft sound mapper like every other application I can't imagine. Of course I could be entirely wrong about that... it's just a guess?

Motherboard has a sound chip but it's disabled in the BIOS. WinXP Pro SP3. All the latest drivers and updates.

I know it's a long shot but I couldn't find anything searching the forums and thought maybe someone else has had this experience and knows how to fix it... or does this game just use 11025 Hz sound samples?

Thanks in advance.


Author Message


Posts: 20730
Rank:


Level: Super Admin

Country: nl
Location: The Netherlands
Occupation:
Age: 45
In-game name: Foxhound

 
#2 Posted at 2010-07-06 07:59        
     
I have never heard or read about this issue and it really doesn't make sense to me. I checked the BI forums but nothing of interest there neither.
Did you check with different drivers? Can you try with the onboard soundcard? Maybe that one works.


Advertisement


Author Message


Posts: 10
Rank:


Level: Member

Country: us
Location: Washington coast
Occupation: jack of all trades, master of none
Age: 54
In-game name: [CoFR]October

 
#3 Posted at 2010-07-06 21:23        
     
Yeah, I can try the onboard chip... it just means switching all my speaker, mic and headphone connections around and rebooting to enable it in the BIOS... and then shutting it down and switching it all back again if I want to pretend I know something about making music! Windows when faced with multiple sound chips scales everything back to the slowest chip, my onboard one, rendering my "good" chip rather useless.

It's just strange because it's not intended to let any software change the sample rate. It's supposedly only adjustable by the user to cap the maximum sample rate in and out. Even if the game used really cruddy 11025 Hz samples it still shouldn't have a problem with a user defined cap that's higher than that!

I'm searching Maudio's forums too.

Any sound designers out there have a way to verify what sample rate is used by Arma2/OA sound samples? It would concern me even more if the game actually uses higher sample rates, which is likely the case, because then that even blows common sense trouble shooting out of the water.

Added 2 hours 11 minutes later:

One user on the M-audio forum is of the opinion that this game does actually use 11025 Hz samples! Could this be true? I have read almost no complaints about the sound quality and am pretty sure that uniform use of that sample rate would raise a mountain of them, if that were case. As I said the first place I noticed it was in the single player campaign during the mission briefings and such. CO voices were quite scratchy sounding and of notable poor quality compared to other games I've played of similar recent vintage (BC2, CS:S, BF2, America's Army, etc.) Do they sound "bad" to anyone else?

If not the case it would be nice if there were a cfg or something that I could force high quality sounds?

This post was edited by Oktyabr (2010-07-06 23:34, ago)