Forum Jump :

Author Message


Posts: 74
Rank:


Level: Member

Country: de
Location:
Occupation:
Age:
In-game name:

 
#1 Posted at 2012-08-26 11:29        
     
hello.

i have a problem.

i made a trigger that is activated on bluforce present, once. but when we play it in multiplayer the trigger is being activated by every player, so instead of one wave of russians, three waves of russians spawn.

when i test it just from the editor it works fine. when i play it in multiplayer without my friend, but only AI teammembers it works fine too.

is that a known problem? does anybody know how to fix this?

thanks.


Author Message

palyarmerc  

I live inside the editor


Posts: 753
Rank:


Level: Member

Country: uk
Location:
Occupation: *Retired from ArmA*
Age:
In-game name: Paly

 
#2 Posted at 2012-08-26 11:37        
     
It's not the trigger as such, but the script.
You need a game logic named 'server'.
The script that spawns the enemy needs to have

if (isServer) then {
code goes here
};

Just say if this is wrong, and what method you are using to 'spawn' the enemy :-)

....that's all folks....!

Advertisement


Author Message


Posts: 1
Rank:


Level: Member

Country: ca
Location: Kahnawake
Occupation:
Age: 30
In-game name:

 
#3 Posted at 2013-03-17 01:50        
     
So all I have to do is put a Game Logic down and call it server and add that code to my scripts. and then do the normal method of having my script called lets say myScript.sqf in my trigger. and it should theoretically work in Multiplayer by only activating once, as if I was testing it alone in the editor?
I know this is now 2013 but still. I'm having the same problem as he was.