Forum Jump :

Author Message


Posts: 3
Rank:


Level: Member

Country: us
Location:
Occupation:
Age:
In-game name:

 
#1 Posted at 2014-07-31 04:22        
     
I have been working on a weapon for about 2 weeks now, and have finally imported it from 3DS Max into O2. But I am having a problem when pressing "e" and applying a texture to both objects on the weapon (Had to seperate for space on the UV Map).

So in Object 1 I have the : Stock, Reciever, Barrel, Tube Magazine, and Front sights.
And for Object 2 I have the : Rear sights, bolt, pump action, trigger guard and trigger.

I have seperate textures for both, and they apply just fine as .paa files and tga. The problem I am having is this... I do not know how to export the .p3d with the textures applied. It works fine in buldozer, but when tested ingame, the shotgun appears but is untextured (white) and you recieve a .paa not found error.

I have applied the textures using "e" as mentioned previously, but have them set to specific paths, and I am thinking that might be the issue. How would I make the texture pathless and textured when exported as a .p3d?

Thanks, Lucky.

Added 34 minutes later:

Here is an album for whats happening with textures. In buldozer, the textures stretch over to the pump and trigger etc from the stock, and the texture goes low res. While in O2, everything appears fine.

http://imgur.com/a/0oTj6

This post was edited by LuckyMrGun (2014-07-31 04:56, ago)


Author Message


Posts: 325
Rank:


Level: Member

Country: br
Location:
Occupation: deanosbeano
Age:
In-game name: deanosbeano

 
#2 Posted at 2014-07-31 08:29        
     
Although development tools can accept paths with prefix drive letters the game cannot
In oxygen options there is a setting to define the development drive which the textures sit on so when you apply the path you do not have E: in your path syntax in the texture bar because the prefux drive is set and thus in gamethe texture is read as correct from the pbo.

However its recommended to use p: as working drive , this is because some tools like mat editor and binarize are default designed to use a p:prefix.

There are other reasons for non texture appearance .

Namespace usage and packing can break the path , for example

P:/dbo_gun
When binarising this the option in binpbo would be use source folder

Namespace usage example

P:/dbo/dbo_gun
When binarising this pbo in options would be
P:/dbo/

Finally in binpbo there is in options a list of files to be carried directly to the pbo this can often be wrong list so check for .rvmat and paa , be careful this listif too long will need checking every time until you have a good string length .

http://forums.bistudio.com/showthread.php?40226-ECL's-record-breaking-attempt-players-on-one-serve&p=619994&viewfull=1#post619994